missing Rtools, should I be worried?

Sorry for the very basic question, but I recently installed a package (after upgrading to R 3.5.3 from R 4) using

> devtools::install(pkg = "W://resources/spacyr/spacyr-master", upgrade = 'never')
WARNING: Rtools is required to build R packages, but is not currently installed.

The install worked fine. Should I be worried about the warning? Does that mean my installation is corrupted?

Thanks again!

1 Like

This means that if you are going to install packages that need compilation, you also have to install Rtools in your system.


thanks @andresrcs, always very useful and timely! So that means I didnt need to compile anything for this one, right? this is why it worked smoothly?

Yes, although this might not be always the case, because binaries are not always available for your OS and R versions.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.