How to get RStudio IDE to use the correct terminal path in Mac OS X?

Apologies for this, this does appear to be a bug on RStudio Desktop for Mac, and we are actively working on a fix but do not have resolution yet. I suggest to follow the linked Github issue above, and keep an eye out for subsequent RStudio releases for a long-term fix. However, in the meantime, a temporary workaround is to create or modify the ~/.Renviron file, setting PATH="/opt/homebrew/bin:/opt/homebrew/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/Applications/Little Snitch.app/Contents/Components:/opt/X11/bin:/Applications/RStudio.app/Contents/MacOS/postback" or whatever the desired value of your PATH variable should be. The PATH should show correctly if you run R directly from your Terminal, and so you can run Sys.getenv("PATH") in R directly (not RStudio) to get the desired value of the PATH to paste into your ~/.Renviron file. We are working to resolve this issue.

1 Like