ERROR: option error has NULL value

I have written an R Markdown script that was running fine up until yesterday.
I haven't changed the code since yesterday

Today I have tried running each chunk separately and I get the error message

ERROR: option error has NULL value repeating over and over.

I have tried including links to files containing the code for the chunk and copying the code directly into the chunk. Neither works.

I have made sure I have the latest version of R Studio and that hasn't helped.

When I copy the code into an R script it runs fine.

I am baffled as to why this is happening.

Check for, install (if necessary) and load the phemisc package (also loads data.table):

if (params$pkginstall == TRUE) {

if (!requireNamespace("devtools", quietly = TRUE)) install.packages("devtools")
if (!requireNamespace("phemisc", quietly = TRUE)) devtools::install_git('')

1 Like

That's a known issue. Try installing a build version of RStudio form here. RStudio 1.2.1568 solved the problem for me on macOS 10.14.6.


Thanks - that fixed it

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.